Getting Started with the SDK

Prerequisites

  • Node version >= v20.x

  • Basic knowledge of Typescript and JavaScript

Don't worry, only very basic knowledge of TypeScript and JavaScript are needed.

We provide a lot of examples to help you if you're unfamiliar and recommend TypeScript for JavaScript Programmers as a great quick start reference.

Installation

The Peanut SDK can be installed using npm or any other package manager:

npm i @squirrel-labs/peanut-sdk

Toggle Verbose

You can set the verbosity level to high which will populate the console with all kinds of logs to make debugging easier:

peanut.toggleVerbose(true)

Last updated